Adobe has this covered in two KB’s, but they might be bit hard to find:
1. Installation
2. How to sort out this popup: “The following plug-in is unresponsive: Shockwave Flash”

No. 2 is a deja-vu of a similar issue in Firefox, the solution there is different though.